Problem to link openbsd user and xfce login screen


#1

Hi, i am new on this website and somebody on a openbsd group tell me to comme here for my question.

 

I have a problem with my fresh install of openbsd5.8/xfce4

 

All is good and stable but my xfce login screen have a bug

When i enter my user/password and press enter is give me the message

Failed to execute the login command

But  when i log in a command prompt session all work in first time and i have no error.

Thank you for your anwser and have a nice day


#2

can you share screenshot here or error log what is problem?

Thanks


#3

http://hpics.li/482470c Is the only thing i got …


#4

What is your /etc/rc.local and nano /etc/rc.conf.local content?


#5

My rc.local is

/usr/local/bin/slim -d

And my rc.conf.local is

Pkg_scripts="dbus_daemon avahi_daemon" dbus_enable=YES


#6

Hi, Dbus_daemon is renamed to messagebus in 5.8 So you need to change your pkg_scripts as well add slim to it.

pkg_scripts=“messagebus avahi_daemon slim”


#7

i got the same error is very weird :confused:


#8

Remove slim and try to login…


#9

I remove slim from the command and i have the same message.

Do you want i remkve completely slim from the system?


#10

Can you try with the default xdm(1) login manager rather than slim?  This way, you will at least be able to determine if the problem is your choice of login manager, or something else in your configuration

  1. Ensure slim is not started manually in /etc/rc.local
  2. Ensure slim is not included in pkg_scripts in /etc/rc.conf.local
  3. Add xdm_flags=Yes to /etc/rc.conf.local, or use rcctl(8) to enable it.

If symptoms remain the same, look to log files in /var/log, such as /var/log/messages and var/log/daemon,


#11

I add # before the command slim in rc.local and abd the xdm command and no the ui don’t start anymore i am going to check the log file


#12

Could you please post the complete contents of /etc/rc.conf.local? And could you please post the complete contents of /etc/rc.local?

Did you edit /etc/rc.conf? If so, what did you change?

I ask because it is not clear from your posts exactly how you have your system configured.


#13

My complete rc.local is:

/usr/local/bin/slim -d

And my rc.conf.local is:

Pkg_scripts="dbus_daemon avahi_daemon"
dbus_enable=YES

I just do this in my rc.local

‘#/usr/local/bin/slim -d’

And now my UI Logon Screen did not start at start up


#14

As mentioned above, "dbus_daemon" does not exist at OpenBSD 5.8 or 5.9.  The name of the dbus startup script is messagebus. You are using old, outdated guidance if you read about "dbus_daemon" and are using OpenBSD 5.8 or 5.9.  (Release 5.7 or older releases are no longer supported, and should be avoided.)

If you are unsure of the startup script name, look at all of the files in /etc/rc.d/ -- if you are running OpenBSD 5.8 or newer, you will not see a file called dbus_daemon.

And as mentioned above, it is not best practice to use /etc/rc.local to start daemons that are available through the rc startup/shutdown system rc.d(8).  Instead, you should be using /etc/rc.conf.local.  And to make that even easier to do, there is an rcctl(8) command that was added at OpenBSD 5.7, which can be used to enable/disable and order daemons and services.  It can start, stop, and restart daemons, but also edits /etc/rc.conf.local for you.

I would like to know if slim is the root cause of your problem.  As I mentioned above, I'd like to know if xdm(1) works instead.  To find out, you must disable slim, then enable xdm. 

Disable slim:  Do not start it via /etc/rc.local.  You can delete the file, or ensure the command is commented out.

Enable xdm: with rcctl(8), all you would need to do is issue this command as root:# rcctl enable xdm

This will add a line to your /etc/rc.conf.local command, enabling xdm at boot.

If you are running OpenBSD 5.8 or later, remove references to dbus from your /etc/rc.conf.local file. You must have missed the guidance from rockworldmi above about this.

If for example, you were to delete both your /etc/rc.local and /etc/rc.conf.local files entirely, and start without either file, you would only need the following to start xdm, messagebus, and avahi-daemon at the next boot:

# rm /etc/rc.local /etc/rc.conf.local

# rcctl enable xdm

# rcctl enable messagebus

# rcctl enable avahi-daemon

---

In addition to the system wide bus, dbus comes with a session bus, started separately from within an .xsession startup script  The details can be found in the dbus README file for OpenBSD stored on your system.  You will find it, along with other OpenBSD-specific README files in /usr/local/share/doc/pkg-readmes.


#15

After all the modif now openbsd start with a ui interface but i thing is openbox or something like this.

Now i am going to see how to start xfce and all going to be good :slight_smile:


#16

The only warning with avahi-daemon i see in the log is he’s unabled to talk to the dbus


#17

Ok now the only problem is to find how i can start xfce4 and all going to be good :smiley:


#18

See your OpenBSD-specific xfce README file. You should find it in /usr/local/share/doc/pkg-readmes.

It has a section on startup, as well as sections on other operational considerations.


#19

My pkg-readmes is empty :confused:


#20

The OpenBSD-specific README has been part of the xfce package since OpenBSD 5.2.  At 5.8, the specific file should be /usr/local/share/doc/pkg-readmes/xfce-4.12p2