OpenBSD Xfce black screen


#1

Hello,

I am using an HDMI => Dport adapter (my screen has only 1 Dport entry) and unfortunately I can’t start Xfce on OpenBSD, I have a black screen after install while booting on it. Also if I Have xdm option installed, it is worse, I can’t even access command line and install Xfce t_t Are HDMI=> Dport adapters compatible with OpenBSD please? Shall I buy a new screen ? Thanks for reading !

Regards


#2

Apparently, while X is running you see nothing on either display if you start X manually or by using xdm(1).

On OpenBSD, multiple display management is best handled with xrandr(1). However, using it requires X to be running and you must be able to see, unless you want to type blindly.

  1. Start an X session with only a single monitor physically connected – poweing off one monitor is insufficient, you must only have a single monitor connected to the system.

  2. Connect the second monitor, and turn it on.

  3. Can you still see the X session on the first monitor? If so, you can use xrandr(1) to configure the displays as you wish. Once you have the displays configured as you wish, you can add them to your ~/.xinitrc script, or add them to xdm(1)'s /etc/X11/xdm/Xstartup script if you wish to use xdm(1) for session management.

I have an external monitor I attach to a laptop’s DisplayPort that I set to a non-default size, and extend “above” my laptop screen. My simple script to enable the configuration is shown below.

#!/bin/sh
xrandr
xrandr --output DP1 --mode 1280x720 --above LVDS1

I use two xrandr commands, as without the first, the second fails to find an active DisplayPort device. I suspect a race condition, but do not actually know the root cause and this particular circumvention works for me.


Edited for clarity


#3

Hi,

Which graphic card are you using? and don’t enable xdm unless your X is set properly. And also what is your dmesg?